Welcome to DU! The truly grassroots left-of-center political community where regular people, not algorithms, drive the discussions and set the standards. Join the community: Create a free account Support DU (and get rid of ads!): Become a Star Member Latest Breaking News Editorials & Other Articles General Discussion The DU Lounge All Forums Issue Forums Culture Forums Alliance Forums Region Forums Support Forums Help & Search

eppur_se_muova

(36,631 posts)
Sun May 5, 2024, 11:18 AM May 5

FIXED(?) problem in Firefox -- not platform-specific, AFAIK. No longer automatically switches to new tab when opened.

Last edited Sun May 5, 2024, 05:38 PM - Edit history (2)

I have my Settings set to automatically switch to a new tab when it is opened, but it quit working a couple of months ago. There have been two or three upgrades since, and it still doesn't work.

I tried using about:config to change these two preferences:
change browser.tabs.loadInBackground to true
browser.tabs.loadDivertedInBackground to true

I also tried another setting, but I don't think it was related.

At first neither of these changes seemed to have any effect. But .... when I went back to look at my Settings, I found "immediately switch to new tab" was now unchecked ! I checked the box to turn it on again and now it works. Earlier, I had tried turning it off, closing Settings, turning it back on and closing Settings, but it had no effect. Hmmmmm. It's like one of my choices in about:config jiggled a switch loose, or something. :/

Any idea what happened here?


THANKS for all who made suggestions. It's still a little unclear if the fix is permanent -- I already had it fail once, but seemed to work reliably after that. Fingers crossed.

4 replies = new reply since forum marked as read
Highlight: NoneDon't highlight anything 5 newestHighlight 5 most recent replies
FIXED(?) problem in Firefox -- not platform-specific, AFAIK. No longer automatically switches to new tab when opened. (Original Post) eppur_se_muova May 5 OP
I use an extension called New Tab Homepage bucolic_frolic May 5 #1
I've used Firefox for several years now EYESORE 9001 May 5 #2
My first thought canetoad May 5 #3
browser.link.open_newwindow is now set to the value of 3. eppur_se_muova May 5 #4

bucolic_frolic

(44,697 posts)
1. I use an extension called New Tab Homepage
Sun May 5, 2024, 11:35 AM
May 5

Used it for about 7 years. No problems. It would override FF internal settings, and you can set the homepage it opens to anything you want.

EYESORE 9001

(26,471 posts)
2. I've used Firefox for several years now
Sun May 5, 2024, 11:40 AM
May 5

and ive noticed this as well. It seems almost random, but I’m guessing it’s in the coding how Firefox handles URLs. I’ve never been so vexed by it that I’ve gone to such lengths to remedy the problem. Id be interested in what you find to fix this issue (if there is one).

canetoad

(17,463 posts)
3. My first thought
Sun May 5, 2024, 05:09 PM
May 5

Was to use tab.focus in some way. I found a page which tells you how to turn OFF focus on new tab, so figured the reverse would be true to turn it on.

https://support.mozilla.org/en-US/questions/1408432

This says to use Settings / General / Tabs .... When you open a link, image..etc switch to it immediately.

eppur_se_muova

(36,631 posts)
4. browser.link.open_newwindow is now set to the value of 3.
Sun May 5, 2024, 05:35 PM
May 5

The last line of your post is what I had already done, over and over. It just didn't "take" until I had gone into the config editor for some reason.

Thanks, I think this would have fixed it if I hadn't already fortuitously fixed it by repeated permutations and combinations.

Latest Discussions»Help & Search»Computer Help and Support»FIXED(?) problem in Firef...